KXPA100 Software Page

IMPORTANT
If you are using a KX3 with your KXPA100, you must load the
latest KX3 firmware (MCU 1.76 or newer) before use.

KX3 Firmware Page

KXPA100 Beta Firmware Revision

---

This version of firmware has new features that require the very latest KXPA100 Utility.

Browse FTP Beta Folder


KXPA100 Production Firmware Revision

MCU 1.35, December 18, 2014  

This version of firmware has new features that require the very latest KXPA100 Utility.

  • Add manual switch to disable amplifier with ATU available:
  • MODE button HOLD now toggles power amplifier bypass.
  • Power ON LED blinks slowly when PA is bypassed.

 

 

KXPA100 Utility and Drivers for Windows

Minimum Operating System Requirements for Elecraft Utilities:

Microsoft Windows: XP Service Pack 3 or later, including Vista, 7, 8, and 8.1.

Apple Mac: OS X 10.6 (Snow Leopard) or later

X86-based Linux: GTK+ 2.8 or later, glibc-2.4, libstdc++.so.6 and cURL. 64-bit Linux requires 32-bit compatibility libraries.

 

Elecraft KXUSB Cable for the KX3

Elecraft offers the KXUSB cable for USB only computers etc.  It uses the FTDI chip set.

Before plugging in this cable to any of your computer's USB ports, you may need to install the correct FTDI USB drivers for your computer's operating system.   Drivers are available for most Windows, Mac, and Linux OS's.  Note that most of the latest Windows 7 operating systems already have the proper drivers for the FTDI chip set and will automatically install them if you just plug the KXUSB cable into a USB port.

KXPA100 Utility Download